Category: Releases

Mailfence disabled websupport for SSLv3 in response to the Poodle

Mailfence disabled websupport for SSLv3 in response to the Poodle

More about Poodle You might have heard that Google discovered a 15 year old flaw in SSL 3.0, a security protocol that turns out isn’t quite as secure as originally...